Tuesday, 10 June 2014

Basic VoIP Configurations - Auto QoS Implemetation.

Basic Switch QoS Application Configurations

Step 1
. Ensure that QoS is globally enabled with the command
mls qos and enter the configuration mode for the interface on which you want to configure Voice VLANs.

Step 2.
Enable the voice VLAN on the switch port and associate a VLAN ID using the interface command switchport voice vlan
vlan-id.

Step 3.
Configure the port to trust CoS or trust DSCP as frames arrive on the switch port using the mls qos trust cosor mls qos trust
dscp commands, respectively. Recall that the mls qos trust cos command directs the switch to trust ingress CoS values whereas
mls qos trust dscp trusts ingress DSCP values. Do not confuse the two commands as each configures the switch
to look at different bits in the frame for classification.


Note: Configuring auto QoS on an interface automatically adds global mls qos srr-queue, class map and policy-map commands
to the running configuration. A number of interface-specific command are also added, including spanning-tree protfast
  - command: mls qos
int range fa0/7-12
auto qos voip trust



DLS1 (Switch 1)


hostname DLS1
int vlan 1
ip address 172.16.1.3 255.255.255.0
no shut


int range fa0/7-8
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active

int range fa0/9-10
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active

int range fa0/11-12
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active


vtp domain SWPOD
vtp version 2
vlan 10
name CD-DATA
exit
vlan 20
name VOICE
exit
vlan 30
name VIDEO


ip routing
int vlan 1
standby 1 ip 172.16.1.1
standby 1 preempt
standby 1 priority 150
exit
int vlan 10
ip address 172.16.10.3 255.255.255.0
standby 1 ip 172.16.10.1
standby 1 preempt
standby 1 priority 150
exit
int vlan 20
ip address 172.16.20.3 255.255.255.0
standby 1 ip 172.16.20.1
standby 1 preempt
standby 1 priority 100
exit
int vlan 30
ip address 172.16.30.3 255.255.255.0
standby 1 ip 172.16.30.1
standby 1 preempt
standby 1 priority 100
exit


mls qos
int range fa0/7-12
auto qos voip trust







DLS2 (Switch 2)

hostname DLS2
int vlan 1
ip address 172.16.1.4 255.255.255.0
no shut


int range fa0/7-8
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active

int range fa0/9-10
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active

int range fa0/11-12
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active


ip routing
int vlan 1
standby 1 ip 172.16.1.1
standby 1 preempt
standby 1 priority 100
exit
int vlan 10
ip address 172.16.10.4 255.255.255.0
standby 1 ip 172.16.10.1
standby 1 preempt
standby 1 priority 100
exit
int vlan 20
ip address 172.16.20.4 255.255.255.0
standby 1 ip 172.16.20.1
standby 1 preempt
standby 1 priority 150
exit
int vlan 30
ip address 172.16.30.4 255.255.255.0
standby 1 ip 172.16.30.1
standby 1 preempt
standby 1 priority 150
exit


mls qos
int range fa0/7-12
auto qos voip trust







ALS1 (Switch 3)

hostname ALS1
int vlan 1
ip address 172.16.1.101 255.255.255.0
no shut
exit
ip default-gateway 172.16.1.1

int range fa0/7-8
switchport mode trunk
channel-group 1 mode active

int range fa0/9-10
switchport mode trunk
channel-group 2 mode active

int range fa0/11-12
switchport mode trunk
channel-group 3 mode active



vtp domain client


int range fa0/15-24
switchport mode access
switchport access vlan 10
switchport voice vlan 20
auto qos voip cisco-phone






ALS2 (Switch 4)

hostname ALS2
int vlan 1
ip address 172.16.1.102 255.255.255.0
no shut
exit
ip default-gateway 172.16.1.1

int range fa0/7-8
switchport mode trunk
channel-group 1 mode active

int range fa0/9-10
switchport mode trunk
channel-group 2 mode active

int range fa0/11-12
switchport mode trunk
channel-group 3 mode active


vtp domain client


int range fa0/15-24
switchport mode access
switchport access vlan 10
switchport voice vlan 20
auto qos voip cisco-phone


int fa0/5
switchport mode access
switchport access vlan 30
mls qos trust cos
mls qos cos 3


This is based on CCNP Switch Lab 7.2 0 Voice Implementation Network.

MPLS Basic Config File

Hi Mark,
I know this post is long over-due :)

This is just a basic MPLS Network configuration that's yet to be developed but has helped me unerstand the basic MPLS operations.

Basic MPLS Configuration Lab

Config File

Router R1

config t
hostname LSR1
interface L0
ip address 172.16.1.1 255.255.255.0
interface fa0/0
ip address 172.16.12.1 255.255.255.0
no shutdown
exit
!
router eigrp 1
no auto-summary
network 172.16.0.0
!
interface fa0/0
mpls ip
exit
end



Router R2

config t
hostname LSR2
interface L0
ip address 172.16.2.1 255.255.255.0
interface fa0/0
ip address 172.16.12.2 255.255.255.0
no shutdown
!
interface serial 0/0/1
ip address 172.16.23.2 255.255.255.0
clockrate 64000
no shutdown
exit
!
router eigrp 1
no auto-summary
network 172.16.0.0
!
interface fa0/0
mpls ip
exit
int s0/0/1
mpls ip
exit
end


Router R3

config t
hostname LSR3
interface L0
ip address 172.16.3.1 255.255.255.0
interface serial 0/0/0
ip address 172.16.23.3 255.255.255.0
no shutdown
exit
!
router eigrp 1
no auto-summary
network 172.16.0.0
!
interface fa0/0
mpls ip
exit
int s0/0/0
mpls ip
exit
end






1. Connectivity Tests:

foreach address {

172.16.12.2
172.16.2.1
172.16.23.2
172.16.23.3
172.16.3.1
172.16.1.1
} {
ping $address
}

Result:

ype escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/33/48 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
LSR1(tcl)#


2. Trace Route:

LSR1#traceroute 172.16.3.1

Type escape sequence to abort.
Tracing the route to 172.16.3.1

  1 172.16.12.2 [MPLS: Label 16 Exp 0] 44 msec 44 msec 48 msec
  2 172.16.23.3 12 msec 12 msec *
LSR1#

Show Commands:

a). show ip route: provides you with the network routing table

LSR1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 5 subnets
D       172.16.23.0 [90/20514560] via 172.16.12.2, 00:01:40, FastEthernet0/0
C       172.16.12.0 is directly connected, FastEthernet0/0
C       172.16.1.0 is directly connected, Loopback0
D       172.16.2.0 [90/156160] via 172.16.12.2, 00:01:40, FastEthernet0/0
D       172.16.3.0 [90/20642560] via 172.16.12.2, 00:01:40, FastEthernet0/0



b). show mpls interfaces (R1, R2, R3): view a quick summary of interfaces configured with MPLS (command based on mpls ip)

LSR1#show mpls interfaces
Interface              IP            Tunnel   BGP Static Operational
FastEthernet0/0        Yes (ldp)     No       No  No     Yes
LSR1#
LSR2#show mpls interfaces
Interface              IP            Tunnel   BGP Static Operational
FastEthernet0/0        Yes (ldp)     No       No  No     Yes
Serial0/0/1            Yes (ldp)     No       No  No     Yes
LSR2#
LSR3#show mpls interfaces
Interface              IP            Tunnel   BGP Static Operational
FastEthernet0/0        Yes           No       No  No     No
Serial0/0/0            Yes (ldp)     No       No  No     Yes
LSR3#



c). show mpls idp discovery: to find out local sources for LDP exchanges

LSR3#show mpls ldp discovery
 Local LDP Identifier:
    172.16.3.1:0
    Discovery Sources:
    Interfaces:
        Serial0/0/0 (ldp): xmit/recv
            LDP Id: 172.16.2.1:0; no host route
LSR3#
LSR2#show mpls ldp discovery
 Local LDP Identifier:
    172.16.2.1:0
    Discovery Sources:
    Interfaces:
        FastEthernet0/0 (ldp): xmit/recv
            LDP Id: 172.16.1.1:0; no host route
        Serial0/0/1 (ldp): xmit/recv
            LDP Id: 172.16.3.1:0; no host route
LSR2#
LSR1#show mpls ldp discovery
 Local LDP Identifier:
    172.16.1.1:0
    Discovery Sources:
    Interfaces:
        FastEthernet0/0 (ldp): xmit/recv
            LDP Id: 172.16.2.1:0; no host route
LSR1#


d). show mpls ldp neighbor: shows ldp adjacencies

LSR1#show mpls ldp nei
    Peer LDP Ident: 172.16.2.1:0; Local LDP Ident 172.16.1.1:0
        TCP connection: 172.16.2.1.60587 - 172.16.1.1.646
        State: Oper; Msgs sent/rcvd: 19/19; Downstream
        Up time: 00:10:25
        LDP discovery sources:
          FastEthernet0/0, Src IP addr: 172.16.12.2
        Addresses bound to peer LDP Ident:
          172.16.12.2     172.16.2.1      172.16.23.2
LSR1#
LSR2#show mpls ldp nei
    Peer LDP Ident: 172.16.1.1:0; Local LDP Ident 172.16.2.1:0
        TCP connection: 172.16.1.1.646 - 172.16.2.1.60587
        State: Oper; Msgs sent/rcvd: 20/20; Downstream
        Up time: 00:10:49
        LDP discovery sources:
          FastEthernet0/0, Src IP addr: 172.16.12.1
        Addresses bound to peer LDP Ident:
          172.16.12.1     172.16.1.1
    Peer LDP Ident: 172.16.3.1:0; Local LDP Ident 172.16.2.1:0
        TCP connection: 172.16.3.1.37941 - 172.16.2.1.646
        State: Oper; Msgs sent/rcvd: 15/15; Downstream
        Up time: 00:06:06
        LDP discovery sources:
          Serial0/0/1, Src IP addr: 172.16.23.3
        Addresses bound to peer LDP Ident:
          172.16.23.3     172.16.3.1
LSR2#
LSR3#show mpls ldp nei
    Peer LDP Ident: 172.16.2.1:0; Local LDP Ident 172.16.3.1:0
        TCP connection: 172.16.2.1.646 - 172.16.3.1.37941
        State: Oper; Msgs sent/rcvd: 15/15; Downstream
        Up time: 00:06:21
        LDP discovery sources:
          Serial0/0/0, Src IP addr: 172.16.23.2
        Addresses bound to peer LDP Ident:
          172.16.12.2     172.16.2.1      172.16.23.2
LSR3#



e). show mpls ldp bindings: displays Label Information Base

LSR1#show mpls ldp binding
  lib entry: 172.16.1.0/24, rev 2
        local binding:  label: imp-null
        remote binding: lsr: 172.16.2.1:0, label: 17
  lib entry: 172.16.2.0/24, rev 6
        local binding:  label: 16
        remote binding: lsr: 172.16.2.1:0, label: imp-null
  lib entry: 172.16.3.0/24, rev 10
        local binding:  label: 18
        remote binding: lsr: 172.16.2.1:0, label: 16
  lib entry: 172.16.12.0/24, rev 4
        local binding:  label: imp-null
        remote binding: lsr: 172.16.2.1:0, label: imp-null
  lib entry: 172.16.23.0/24, rev 8
        local binding:  label: 17
        remote binding: lsr: 172.16.2.1:0, label: imp-null

LSR2#show mpls ldp binding
  lib entry: 172.16.1.0/24, rev 10
        local binding:  label: 17
        remote binding: lsr: 172.16.1.1:0, label: imp-null
        remote binding: lsr: 172.16.3.1:0, label: 16
  lib entry: 172.16.2.0/24, rev 2
        local binding:  label: imp-null
        remote binding: lsr: 172.16.1.1:0, label: 16
        remote binding: lsr: 172.16.3.1:0, label: 17
  lib entry: 172.16.3.0/24, rev 8
        local binding:  label: 16
        remote binding: lsr: 172.16.1.1:0, label: 18
        remote binding: lsr: 172.16.3.1:0, label: imp-null
  lib entry: 172.16.12.0/24, rev 4
        local binding:  label: imp-null
        remote binding: lsr: 172.16.1.1:0, label: imp-null
        remote binding: lsr: 172.16.3.1:0, label: 18
  lib entry: 172.16.23.0/24, rev 6
        local binding:  label: imp-null
        remote binding: lsr: 172.16.1.1:0, label: 17
        remote binding: lsr: 172.16.3.1:0, label: imp-null

LSR3#show mpls ldp binding
  lib entry: 172.16.1.0/24, rev 2
        local binding:  label: 16
        remote binding: lsr: 172.16.2.1:0, label: 17
  lib entry: 172.16.2.0/24, rev 4
        local binding:  label: 17
        remote binding: lsr: 172.16.2.1:0, label: imp-null
  lib entry: 172.16.3.0/24, rev 6
        local binding:  label: imp-null
        remote binding: lsr: 172.16.2.1:0, label: 16
  lib entry: 172.16.12.0/24, rev 8
        local binding:  label: 18
        remote binding: lsr: 172.16.2.1:0, label: imp-null
  lib entry: 172.16.23.0/24, rev 10
        local binding:  label: imp-null
        remote binding: lsr: 172.16.2.1:0, label: imp-null

Project Time-Schedule

Project Plan - Voice over MPLS (2014)
Outcomes
March 2014
April 2014
May 2014
June 2014
July 2014
Aug 2014
Sep 2014
Oct 2014
Nov 2014
Total (Hrs)










1
Initial negotiation (i.e. understanding the problem and requirements). (Hrs.)
(20)
03/03 – 15/03








 20

Actual hours
15








15
2
Initial plan, budget & proposal submission (hrs.)
( 12)
17/03 – 28/03
(12 )
01/04 – 14/04







24

Actual hours
 12
12






24
3
Client meetings (hrs.)
4
4
4
4  
4  

30

Actual hours
2





2
4
MPLS/VoIP research, MPLS Lab
(48)
01/04 – 30/04






48

Actual hours







5
VoIP configuration tests, result analysis
(48)
01/05 – 31/05





48

Actual hours




6
MPLS configuration tests, result analysis progress report
(48)
01/06 – 30/06



48

Actual hours



7
Protocol integration research, lab simulation , result analysis




(48)
01/07 – 31/07




48

Actual hours







8
Network measurements, basic security implementation



(48)
01/08 – 31/08

48

Actual hours









10
Feature implementation, network capacity test, result analysis






(48)
01/09 – 31/09

48

Actual hours









11
Test results and analysis, Final report draft




(24)
01/09 (Start)
(24)
15/10 (End)

48

Actual hours










12
Final presentation, P&L/project Report submission







(48)
01/10 – 30/10

48
12
Total Budget Hours ()
36
62
52
52
52
52
76
76
(458)